Jump to content
Ornithology Exchange
  • 0
sabiina.m

Issue with loading Geosphere

Question

Hello! 

I am currently using FLightR to analyze geolocator data for migration routes and timing events, but I have been having issues specifically with loading the package geosphere (sometimes the package MASS is an issue too, but geosphere only works less than half the time for the past month I'd say). I am using geosphere to produce final FLightR maps showing migration results and movements represented by a calendar year legend. 

 

I am working on two monitors, one computer, where very often I have two different RStudios running and when installing geosphere it continually says geosphere was successfully unpacked in both R sessions, but then only one or none of the maps will load after running the following line,

 

"map.FLightR.ggmap(Result163, seasonal.donut.location=NULL, save=TRUE)"

 

I am currently running version 3.4.1 "Single Candle", and I have also used/run version 3.3.2 "Sincere Pumpkin Patch" where geosphere also used to only work occasionally. Geosphere does not appear to be on the update packages list, therefore any recommendations on how to get geosphere to consistently work?

 

Thank you so much for your time and help in advance!

Sabina 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

  Hi Sabina,

 I am not sure there can be geosphere issue, at least I do not use it in FLightR.

You can always run 

library(geosphere) before running the function.

   Sometimes seasonal donut does not work. For that you should try 

library(grid) before running the function. 

 

but then only one or none of the maps will load after running the following line

 

 But how many maps you expect there?

 Regards,

   Eldar

Share this post


Link to post
Share on other sites
  • 0

Hi Eldar,

 

Thank you for your response!

 

I think I was unclear when I said "only one or none of the maps will load", what I was referring to was when I have 2 monitors and 2 different R studios open, sometimes geosphere will load and run successfully in one studio, but not the other (even when they are the same version and have had the same packages downloaded, strange I thought). But as of lately, the last couple weeks, geosphere has not worked/downloaded/installed at all to produce the final FLightR maps that I require visually and for my migration route analysis. I thought you did require geosphere in FLightR to produce the final FLightR maps but you mentioned you do not use it in FLightR?

 

The error message I get is as follows:

 

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[]) : 
  there is no package called ‘geosphere’
 
 
Thanks for your time and help!
 
Sabina

Share this post


Link to post
Share on other sites
  • 0

 Hi Sabina,

What is your FLightR version? Try installing the latest from github.

devtools::install_github('eldarrak/FLightR')

and what happens if you run
 

install.packages('geosphere')

before running the plotting function?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×