Jump to content
Ornithology Exchange

readTem2 BASTag temperature files


Recommended Posts

Hi! I am trying to open my .tem files from MK3 geolocators. The problem is that I don't know how, I downloaded the .tem file with the temperature with comas and not points. So, every time I try to open my file I get an error:

> d.deg_prim <- readTem2(paste0(tagdata,".tem"), skip = 1)
Error in read.table(file = file, header = header, sep = sep, quote = quote,  : 
  more columns than column names

So looks my .tem file:

255,19,-0,499986,

ok,06/04/19 12:17:54,43561.512431,12,625000

ok,06/04/19 13:13:42,43561.551181,12,750000

ok,06/04/19 14:20:45,43561.597743,12,750000

ok,07/04/19 11:41:48,43562.487361,12,500000

Any ideas of how can I solve this problem? 

I tried to change this from Excel but then the file can't be saved as .tem file. 

Thanks!!!!

Link to post
Share on other sites
  • 2 months later...

Hi! Your question is a few months old already so I hope you managed fixed the issue already, otherwise it seems to me that it could be a decimal separator issue. In the example you shared, the separator for the temperature is a coma rather than a point and I imagine that the "sep" parameter of the read.table function is set as coma to read csv type files (which seems to be the case of yours). So the function tries to assign 5 values to only 4 headers.

This decimal separator issue is common with computers set in certain languages (e.g., french decimal separator is a coma).

Hope it helps

Link to post
Share on other sites
×
×
  • Create New...